WordPress 2.8.5: Hardening Release (Should I wait for 2.9?)

It seems wordpress comes out with a new update every couple of months, but this is for good reason. When vulnerabilities are found in software, the company will release a patch to fix it, right? Well wordpress is no different. If you are running anything less than 2.8.5 (released yesterday) then you need to upgrade NOW; don’t wait for 2.9.

There were numerous security issues with the release of 2.8 that they found and patched with several releases (up to 2.8.4). Now that 2.8.5 is out, it will fix the follow security gaps:

  • A fix for the Trackback Denial-of-Service attack that is currently being seen.
  • Removal of areas within the code where php code in variables was evaluated.
  • Switched the file upload functionality to be whitelisted for all users including Admins.
  • Retiring of the two importers of Tag data from old plugins.

What does that mean to you? It means less chance for a hack or breach into your blog. What does that affect? It could affect a lot of things, not just your blog. After a breach is found in your software, it is open to viruses and hacks that can get into your server/host and destroy other parts of your entire server (and possibly others).

So unless you want a total online meltdown, upgrade your wordpress please. 😀

If you aren’t comfortable backing up your site and upgrading your blog, kimtown can do it for you. If you have ONE wordpress to upgrade it’s $50 and you can purchase that HERE.

If you have TWO or more wordpress that you’ll need to upgrade they are only $30 each. You can purchase that HERE.

Read the full post by wordpress.org

One Reply to “WordPress 2.8.5: Hardening Release (Should I wait for 2.9?)”

Comments are closed.

Newsletter

Enter your email address to sign up for the kimtown newsletter.

Web Design, Hosting, Programming and Coding.

Contact us

Jacksonville, FL

(904) 479-KIMT

kimtownstudios@gmail.com

Instagram

Popular Tags

CLOSE
X
Add to cart